Ventuz.OSC Namespace

Ventuz OSC Help
Ventuz.OSC Namespace
Namespaces ► Ventuz.OSC
Ventuz.OSC namespace provides interfaces and classes for communication with Ventuz scene via the Open Sound Control protocol.
Declaration Syntax
C# Visual Basic Visual C++
namespace Ventuz.OSC
Namespace Ventuz.OSC
namespace Ventuz.OSC
Types
All Types Classes Structures Delegates
Icon Type Description
NetBase
Baseclass for all network send and receive classes

NetReader
Baseclass for all implementations reading OSC message from the network.

NetWriter
Baseclass for all implementations writing OSC message to the network.

OscBundle
An OscBundle holds one or more OscElements and bundles them to one message. Only OscBundle can be sent or received. Therefore the simplest Osc message is a OscBundle holding one OscElement

OscBundleHandler
This event type is thrown by an OscDispatcher after calling OscDispatcher.Purge for each OscBundle received on any NetReader attached to the OscDispatcher

OscDispatcher
An OscDispatcher manages multiple instances of NetReaders.
It fetches all NetReaders by calling the Purge method. For each received OscBundle and for each OscElement the OscDispather fires an event (Bundle and Element)

OscElement
OscElement holds the real data send/received to/from a OSC host in the network, so called Arguments. An OscElement is addressing an OSC address, which the receiver is listening to. One Element can transfer one or more data words. Following types are supported:
primitive types:
CopyC#
int, float, string, long, ulong, double, char, bool

complex types:
CopyC#
byte[] (binary data), OscSymbol, Color, OscMidiMessage

extended types (not part of the OSC specification):
CopyC#
OscUnicodeString, OscImage

OscElementHandler
This event type is thrown by an OscDispatcher after calling OscDispatcher.Purge for each OscElement received on any NetReader attached to the OscDispatcher

OscException
This exception is thrown, if any errors occured regarding the OSC protocol

OscGroup
The OscGroup allows to group multiple controls together so that all OscElements created by the Control are send in one OscBundle. To trigger the actual send of this bundle, you need to attach a Button to this OscGroup as well and set the GroupTrigger property to true.

OscImage
Experimental!
The OscImage is an OSC extension (not specified in the OSC specification). OscImage allows to use an Image as an argument of an OscElement. The image is saved in PNG format and transferred as a binary argument where the first 4 bytes are filled with 'P' 'N' 'G' 'I' (PNG-Image)
If the receiving side uses the same Ventuz.OSC as well, the OscElement recognizes the argument as an OscImage. Other implementation will receive a binary data argument.

OscManager
The OscManagerComponent controls one OSC sending channels. All Controls attached to this Manager are sending their messages to the target OSC receiver specified in this manager

OscMessage
OscMessage is the base class of OscElement and OscBundle. It represents the smallest to be send/received via the OSC protocol

OscMidiMessage
The OscMidiMessage structure combines the components of a Midi Message and allows to use it as an argument of an OscElement.

OscSymbol
The OscSymbol is a special version of a string argument in an OscElement. It's not transferred as a simple string. It's using the Symbol tagging. See OSC specifications for further details.

OscUnicodeString
The OscUnicodeString is an OSC extension (not specified in the OSC specification) It simply transfers a BigEndianUnicode encoded string (.NET-String) as a binary argument. The binary data is marked with the bytes 'B' 'E' 'U' 'C' (Big-Endian-Uni-Code) If the receiving side uses the same Ventuz.OSC as well, the OscElement recognizes the argument as an OscUnicodeString. Other implementation will receive a binary data argument.

UdpReader
An UdpReader receives OscBundles from UDP unicast or multicast sockets.

UdpWriter
An UdpWriter sends OscBundles to a unicast or multicast IP address.

Send comments on this topic to support@ventuz.com

© 2008 Ventuz Technology Group. All rights reserved.


NetBase Class

NetBase Class
Namespaces ► Ventuz.OSC ► NetBase
Baseclass for all network send and receive classes
Declaration Syntax
C# Visual Basic Visual C++
public class NetBase : IDisposable
Public Class NetBase _
    Implements IDisposable
public ref class NetBase : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetBase()()() | this constructor does nothing. It´s just there to avoid a direct instancing of an object of this type.
 | Dispose()()() | Disposes and closes a network connection
 | Dispose(Boolean) | Disposes and closes a network connection
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Finalizer (Overrides Object.Finalize()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | NetBase
 |  | NetReader
 |  | NetWriter

Send comments on this topic to support@ventuz.com

© 2008 Ventuz Technology Group. All rights reserved.

Assembly: Ventuz.OSC (Module: Ventuz.OSC) Version: 1.3.0.0


NetBase Constructor

NetBase Constructor
Namespaces ► Ventuz.OSC ► NetBase ► NetBase()()()
this constructor does nothing. It´s just there to avoid a direct instancing of an object of this type.
Declaration Syntax
C# Visual Basic Visual C++
protected NetBase()
Protected Sub New
protected:
NetBase()


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► NetBase ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Disposes and closes a network connection
 | Dispose(Boolean) | Disposes and closes a network connection


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► NetBase ► Dispose()()()
Disposes and closes a network connection
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Ventuz.OSC ► NetBase ► Dispose(Boolean)
Disposes and closes a network connection
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)
false, if instance is dispose by the Garbage Collector


Finalize Method

Finalize Method
Namespaces ► Ventuz.OSC ► NetBase ► Finalize()()()
Finalizer
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override


NetReader Class

NetReader Class
Namespaces ► Ventuz.OSC ► NetReader
Baseclass for all implementations reading OSC message from the network.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class NetReader : NetBase
Public MustInherit Class NetReader _
    Inherits NetBase
public ref class NetReader abstract : public NetBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetReader()()() | This constructor does nothing. It´s just there to avoid a direct instancing of an object of this type.
 | Dispose()()() | Disposes and closes a network connection (Inherited from NetBase.)
 | Dispose(Boolean) | Disposes and closes a network connection (Inherited from NetBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Finalizer (Inherited from NetBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Receive()()() | Reads an OSC message from the network synchronously. If a bundle was received (a non null pointer was returned) the caller should call this method again to make sure that the whole input buffer was fetched completly.
 | ReceiveBundle()()() | Obsolete. Reads an OSC bundle from the network synchronously. If a bundle was received (a non null pointer was returned) the caller should call this method again to make sure that the whole input buffer was fetched completly.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | NetBase
 |  | NetReader
 |  |  | UdpReader


NetReader Constructor

NetReader Constructor
Namespaces ► Ventuz.OSC ► NetReader ► NetReader()()()
This constructor does nothing. It´s just there to avoid a direct instancing of an object of this type.
Declaration Syntax
C# Visual Basic Visual C++
protected NetReader()
Protected Sub New
protected:
NetReader()


Receive Method

Receive Method
Namespaces ► Ventuz.OSC ► NetReader ► Receive()()()
Reads an OSC message from the network synchronously. If a bundle was received (a non null pointer was returned) the caller should call this method again to make sure that the whole input buffer was fetched completly.
Declaration Syntax
C# Visual Basic Visual C++
public abstract OscMessage Receive()
Public MustOverride Function Receive As OscMessage
public:
virtual OscMessage^ Receive() abstract
Return Value

[Missing <returns> documentation for M:Ventuz.OSC.NetReader.Receive]


ReceiveBundle Method

ReceiveBundle Method
Namespaces ► Ventuz.OSC ► NetReader ► ReceiveBundle()()()
Reads an OSC bundle from the network synchronously. If a bundle was received (a non null pointer was returned) the caller should call this method again to make sure that the whole input buffer was fetched completly.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use Receive()")]
public OscBundle ReceiveBundle()
<ObsoleteAttribute("Please use Receive()")> _
Public Function ReceiveBundle As OscBundle
[ObsoleteAttribute(L"Please use Receive()")]
public:
OscBundle^ ReceiveBundle()
Return Value
a valid osc bundle or null


NetWriter Class

NetWriter Class
Namespaces ► Ventuz.OSC ► NetWriter
Baseclass for all implementations writing OSC message to the network.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class NetWriter : NetBase
Public MustInherit Class NetWriter _
    Inherits NetBase
public ref class NetWriter abstract : public NetBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetWriter()()() | This constructor does nothing. It´s just there to avoid a direct instancing of an object of this type.
 | Dispose()()() | Disposes and closes a network connection (Inherited from NetBase.)
 | Dispose(Boolean) | Disposes and closes a network connection (Inherited from NetBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Finalizer (Inherited from NetBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Send(OscMessage) | sends an OSC message to the network
 | SendBundle(OscBundle) | Obsolete. sends a bundle to the network
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | NetBase
 |  | NetWriter
 |  |  | UdpWriter


NetWriter Constructor

NetWriter Constructor
Namespaces ► Ventuz.OSC ► NetWriter ► NetWriter()()()
This constructor does nothing. It´s just there to avoid a direct instancing of an object of this type.
Declaration Syntax
C# Visual Basic Visual C++
protected NetWriter()
Protected Sub New
protected:
NetWriter()


Send Method (message)

Send Method (message)
Namespaces ► Ventuz.OSC ► NetWriter ► Send(OscMessage)
sends an OSC message to the network
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Send(
    OscMessage message
)
Public MustOverride Sub Send ( _
    message As OscMessage _
)
public:
virtual void Send(
    OscMessage^ message
) abstract
Parameters
message (OscMessage)

[Missing <param name="message"/> documentation for "M:Ventuz.OSC.NetWriter.Send(Ventuz.OSC.OscMessage)"]


SendBundle Method (bundle)

SendBundle Method (bundle)
Namespaces ► Ventuz.OSC ► NetWriter ► SendBundle(OscBundle)
sends a bundle to the network
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use Send(OscMessage instead)")]
public void SendBundle(
    OscBundle bundle
)
<ObsoleteAttribute("Please use Send(OscMessage instead)")> _
Public Sub SendBundle ( _
    bundle As OscBundle _
)
[ObsoleteAttribute(L"Please use Send(OscMessage instead)")]
public:
void SendBundle(
    OscBundle^ bundle
)
Parameters
bundle (OscBundle)
OscBundle to be send


OscBundle Class

OscBundle Class
Namespaces ► Ventuz.OSC ► OscBundle
An OscBundle holds one or more OscElements and bundles them to one message. Only OscBundle can be sent or received. Therefore the simplest Osc message is a OscBundle holding one OscElement
Declaration Syntax
C# Visual Basic Visual C++
public class OscBundle : OscMessage
Public Class OscBundle _
    Inherits OscMessage
public ref class OscBundle : public OscMessage
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscBundle()()() | Creates a new empty OscBundle. Use the AddElement method to add OscElements to this OscBundle. The TimeStamp will be set to 'immediate' (1)
 | OscBundle(UInt64) | Creates a new empty OscBundle with the specified TimeTag. The TimeTag can be changed later as well. Use the AddElement method to add OscElements to this OscBundle.
 | OscBundle(DateTime) | Creates a new empty OscBundle with the specified TimeTag. The TimeTag can be changed later as well. Use the AddElement method to add OscElements to this OscBundle.
 | OscBundle(UInt64, OscMessage) | Creates an OscBundle with the specified TimeTag and adds one OscElement to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, OscMessage) | Creates an OscBundle with the specified TimeTag and adds one OscElement to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(UInt64, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds two OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds two OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(UInt64, OscMessage, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds three OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, OscMessage, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds three OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(UInt64, array<OscElement>[]()[]) | Creates an OscBundle with the specified TimeTag and adds a list of OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, array<OscElement>[]()[]) | Creates an OscBundle with the specified TimeTag and adds a list of OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | AddElement(OscMessage) | Adds one further OscElement to the OscBundle
 | DateTime | Get or sets the TimeTag attached to this OscBundle as DateTime. A DateTime value of DateTime.MinValue represents the OSC/NTP immediate (1UL)
 | Elements | Gets a collection of all OscElements in the OscBundle
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Immediate | represents the OSC time tag 'Immediate' and has the value 1
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TimeTag | Get or sets the TimeTag attached to this OscBundle
 | ToDateTime(UInt64) | Convert an OSC-Timestamp (NTP-Timestamp) into a .Net DateTime object. A value of one or zero return DateTime.MinValue
 | ToStream(Stream) | Writes the OscBundle to a stream according to the OSC protocol (Overrides OscMessage.ToStream(Stream).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToTimeStamp(DateTime) | Convert a .Net DateTime object into an OSC-Timestamp (NTP-Timestamp) A DateTime value before 1st Jan 1900 return an OSC/NTP immediate (1UL)
Examples
CopyC#
class MyClass
{
    UdpWriter    udpWriter;

    public MyClass()
    {
        this.udpWriter = new UdpWriter( "228.1.1.1", 7000 );
    }

    public void Send()
    {
        udpWriter.SendBundle( new OscBundle( 0, new OscElement( "/Target", 1 ) ) );
    }
}
Inheritance Hierarchy
Object
 | OscMessage
 |  | OscBundle


OscBundle Constructor

OscBundle Constructor
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle()()()
Members
Icon | Member | Description
 | OscBundle()()() | Creates a new empty OscBundle. Use the AddElement method to add OscElements to this OscBundle. The TimeStamp will be set to 'immediate' (1)
 | OscBundle(UInt64) | Creates a new empty OscBundle with the specified TimeTag. The TimeTag can be changed later as well. Use the AddElement method to add OscElements to this OscBundle.
 | OscBundle(DateTime) | Creates a new empty OscBundle with the specified TimeTag. The TimeTag can be changed later as well. Use the AddElement method to add OscElements to this OscBundle.
 | OscBundle(UInt64, OscMessage) | Creates an OscBundle with the specified TimeTag and adds one OscElement to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, OscMessage) | Creates an OscBundle with the specified TimeTag and adds one OscElement to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(UInt64, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds two OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds two OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(UInt64, OscMessage, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds three OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, OscMessage, OscMessage, OscMessage) | Creates an OscBundle with the specified TimeTag and adds three OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(UInt64, array<OscElement>[]()[]) | Creates an OscBundle with the specified TimeTag and adds a list of OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
 | OscBundle(DateTime, array<OscElement>[]()[]) | Creates an OscBundle with the specified TimeTag and adds a list of OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.


OscBundle Constructor

OscBundle Constructor
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle()()()
Creates a new empty OscBundle. Use the AddElement method to add OscElements to this OscBundle. The TimeStamp will be set to 'immediate' (1)
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle()
Public Sub New
public:
OscBundle()


OscBundle Constructor (timeTag)

OscBundle Constructor (timeTag)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(DateTime)
Creates a new empty OscBundle with the specified TimeTag. The TimeTag can be changed later as well. Use the AddElement method to add OscElements to this OscBundle.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    DateTime timeTag
)
Public Sub New ( _
    timeTag As DateTime _
)
public:
OscBundle(
    DateTime timeTag
)
Parameters
timeTag (DateTime)
TimeTag for the new OscBundle


OscBundle Constructor (timeTag, elements)

OscBundle Constructor (timeTag, elements)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(DateTime, array<OscElement>[]()[])
Creates an OscBundle with the specified TimeTag and adds a list of OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    DateTime timeTag,
    params OscElement[] elements
)
Public Sub New ( _
    timeTag As DateTime, _
    ParamArray elements As OscElement() _
)
public:
OscBundle(
    DateTime timeTag,
    ... array<OscElement^>^ elements
)
Parameters
timeTag (DateTime)
TimeTag for the new OscBundle
elements (array< OscElement >[]()[])
List of OscElements to add


OscBundle Constructor (timeTag, element1)

OscBundle Constructor (timeTag, element1)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(DateTime, OscMessage)
Creates an OscBundle with the specified TimeTag and adds one OscElement to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    DateTime timeTag,
    OscMessage element1
)
Public Sub New ( _
    timeTag As DateTime, _
    element1 As OscMessage _
)
public:
OscBundle(
    DateTime timeTag,
    OscMessage^ element1
)
Parameters
timeTag (DateTime)
TimeTag for the new OscBundle
element1 (OscMessage)
OscMessage to add


OscBundle Constructor (timeTag, element1, element2)

OscBundle Constructor (timeTag, element1, element2)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(DateTime, OscMessage, OscMessage)
Creates an OscBundle with the specified TimeTag and adds two OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    DateTime timeTag,
    OscMessage element1,
    OscMessage element2
)
Public Sub New ( _
    timeTag As DateTime, _
    element1 As OscMessage, _
    element2 As OscMessage _
)
public:
OscBundle(
    DateTime timeTag,
    OscMessage^ element1,
    OscMessage^ element2
)
Parameters
timeTag (DateTime)
TimeTag for the new OscBundle
element1 (OscMessage)
First OscMessage to add
element2 (OscMessage)
Second OscMessage to add


OscBundle Constructor (timeTag, element1, element2, element3)

OscBundle Constructor (timeTag, element1, element2, element3)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(DateTime, OscMessage, OscMessage, OscMessage)
Creates an OscBundle with the specified TimeTag and adds three OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    DateTime timeTag,
    OscMessage element1,
    OscMessage element2,
    OscMessage element3
)
Public Sub New ( _
    timeTag As DateTime, _
    element1 As OscMessage, _
    element2 As OscMessage, _
    element3 As OscMessage _
)
public:
OscBundle(
    DateTime timeTag,
    OscMessage^ element1,
    OscMessage^ element2,
    OscMessage^ element3
)
Parameters
timeTag (DateTime)
TimeTag for the new OscBundle
element1 (OscMessage)
First OscMessage to add
element2 (OscMessage)
Second OscMessage to add
element3 (OscMessage)
Third OscMessage to add


OscBundle Constructor (timeTag)

OscBundle Constructor (timeTag)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(UInt64)
Creates a new empty OscBundle with the specified TimeTag. The TimeTag can be changed later as well. Use the AddElement method to add OscElements to this OscBundle.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    ulong timeTag
)
Public Sub New ( _
    timeTag As ULong _
)
public:
OscBundle(
    unsigned long long timeTag
)
Parameters
timeTag (UInt64)
TimeTag for the new OscBundle


OscBundle Constructor (timeTag, elements)

OscBundle Constructor (timeTag, elements)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(UInt64, array<OscElement>[]()[])
Creates an OscBundle with the specified TimeTag and adds a list of OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    ulong timeTag,
    params OscElement[] elements
)
Public Sub New ( _
    timeTag As ULong, _
    ParamArray elements As OscElement() _
)
public:
OscBundle(
    unsigned long long timeTag,
    ... array<OscElement^>^ elements
)
Parameters
timeTag (UInt64)
TimeTag for the new OscBundle
elements (array< OscElement >[]()[])
List of OscElements to add


OscBundle Constructor (timeTag, element1)

OscBundle Constructor (timeTag, element1)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(UInt64, OscMessage)
Creates an OscBundle with the specified TimeTag and adds one OscElement to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    ulong timeTag,
    OscMessage element1
)
Public Sub New ( _
    timeTag As ULong, _
    element1 As OscMessage _
)
public:
OscBundle(
    unsigned long long timeTag,
    OscMessage^ element1
)
Parameters
timeTag (UInt64)
TimeTag for the new OscBundle
element1 (OscMessage)
OscMessage to add


OscBundle Constructor (timeTag, element1, element2)

OscBundle Constructor (timeTag, element1, element2)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(UInt64, OscMessage, OscMessage)
Creates an OscBundle with the specified TimeTag and adds two OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    ulong timeTag,
    OscMessage element1,
    OscMessage element2
)
Public Sub New ( _
    timeTag As ULong, _
    element1 As OscMessage, _
    element2 As OscMessage _
)
public:
OscBundle(
    unsigned long long timeTag,
    OscMessage^ element1,
    OscMessage^ element2
)
Parameters
timeTag (UInt64)
TimeTag for the new OscBundle
element1 (OscMessage)
First OscMessage to add
element2 (OscMessage)
Second OscMessage to add


OscBundle Constructor (timeTag, element1, element2, element3)

OscBundle Constructor (timeTag, element1, element2, element3)
Namespaces ► Ventuz.OSC ► OscBundle ► OscBundle(UInt64, OscMessage, OscMessage, OscMessage)
Creates an OscBundle with the specified TimeTag and adds three OscElements to it. The TimeTag can be changed later as well. Use the AddElement method to add more OscElements.
Declaration Syntax
C# Visual Basic Visual C++
public OscBundle(
    ulong timeTag,
    OscMessage element1,
    OscMessage element2,
    OscMessage element3
)
Public Sub New ( _
    timeTag As ULong, _
    element1 As OscMessage, _
    element2 As OscMessage, _
    element3 As OscMessage _
)
public:
OscBundle(
    unsigned long long timeTag,
    OscMessage^ element1,
    OscMessage^ element2,
    OscMessage^ element3
)
Parameters
timeTag (UInt64)
TimeTag for the new OscBundle
element1 (OscMessage)
First OscMessage to add
element2 (OscMessage)
Second OscMessage to add
element3 (OscMessage)
Third OscMessage to add


AddElement Method (element)

AddElement Method (element)
Namespaces ► Ventuz.OSC ► OscBundle ► AddElement(OscMessage)
Adds one further OscElement to the OscBundle
Declaration Syntax
C# Visual Basic Visual C++
public void AddElement(
    OscMessage element
)
Public Sub AddElement ( _
    element As OscMessage _
)
public:
void AddElement(
    OscMessage^ element
)
Parameters
element (OscMessage)
OscMessage to be added


DateTime Property

DateTime Property
Namespaces ► Ventuz.OSC ► OscBundle ► DateTime
Get or sets the TimeTag attached to this OscBundle as DateTime. A DateTime value of DateTime.MinValue represents the OSC/NTP immediate (1UL)
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; set; }
Public Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}


Elements Property

Elements Property
Namespaces ► Ventuz.OSC ► OscBundle ► Elements
Gets a collection of all OscElements in the OscBundle
Declaration Syntax
C# Visual Basic Visual C++
public ICollection Elements { get; }
Public ReadOnly Property Elements As ICollection
public:
property ICollection^ Elements {
    ICollection^ get ();
}


Immediate Field

Immediate Field
Namespaces ► Ventuz.OSC ► OscBundle ► Immediate
represents the OSC time tag 'Immediate' and has the value 1
Declaration Syntax
C# Visual Basic Visual C++
public const ulong Immediate
Public Const Immediate As ULong
public:
literal unsigned long long Immediate


TimeTag Property

TimeTag Property
Namespaces ► Ventuz.OSC ► OscBundle ► TimeTag
Get or sets the TimeTag attached to this OscBundle
Declaration Syntax
C# Visual Basic Visual C++
public ulong TimeTag { get; set; }
Public Property TimeTag As ULong
public:
property unsigned long long TimeTag {
    unsigned long long get ();
    void set (unsigned long long value);
}


ToDateTime Method (timeStamp)

ToDateTime Method (timeStamp)
Namespaces ► Ventuz.OSC ► OscBundle ► ToDateTime(UInt64)
Convert an OSC-Timestamp (NTP-Timestamp) into a .Net DateTime object. A value of one or zero return DateTime.MinValue
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime ToDateTime(
    ulong timeStamp
)
Public Shared Function ToDateTime ( _
    timeStamp As ULong _
) As DateTime
public:
static DateTime ToDateTime(
    unsigned long long timeStamp
)
Parameters
timeStamp (UInt64)
OSC-Timestamp to convert
Return Value
DateTime


ToStream Method (stream)

ToStream Method (stream)
Namespaces ► Ventuz.OSC ► OscBundle ► ToStream(Stream)
Writes the OscBundle to a stream according to the OSC protocol
Declaration Syntax
C# Visual Basic Visual C++
public override void ToStream(
    Stream stream
)
Public Overrides Sub ToStream ( _
    stream As Stream _
)
public:
virtual void ToStream(
    Stream^ stream
) override
Parameters
stream (Stream)
stream to write this OscBundle to


ToTimeStamp Method (dateTime)

ToTimeStamp Method (dateTime)
Namespaces ► Ventuz.OSC ► OscBundle ► ToTimeStamp(DateTime)
Convert a .Net DateTime object into an OSC-Timestamp (NTP-Timestamp) A DateTime value before 1st Jan 1900 return an OSC/NTP immediate (1UL)
Declaration Syntax
C# Visual Basic Visual C++
public static ulong ToTimeStamp(
    DateTime dateTime
)
Public Shared Function ToTimeStamp ( _
    dateTime As DateTime _
) As ULong
public:
static unsigned long long ToTimeStamp(
    DateTime dateTime
)
Parameters
dateTime (DateTime)
DateTime object to convert
Return Value
OSC-Timestamp


OscBundleHandler Delegate

OscBundleHandler Delegate
Namespaces ► Ventuz.OSC ► OscBundleHandler
This event type is thrown by an OscDispatcher after calling OscDispatcher.Purge for each OscBundle received on any NetReader attached to the OscDispatcher
Declaration Syntax
C# Visual Basic Visual C++
public delegate void OscBundleHandler(
    OscDispatcher dispatcher,
    OscBundle bundle
)
Public Delegate Sub OscBundleHandler ( _
    dispatcher As OscDispatcher, _
    bundle As OscBundle _
)
public delegate void OscBundleHandler(
    OscDispatcher^ dispatcher,
    OscBundle^ bundle
)
Parameters
dispatcher (OscDispatcher)
bundle (OscBundle)


OscDispatcher Class

OscDispatcher Class
Namespaces ► Ventuz.OSC ► OscDispatcher
An OscDispatcher manages multiple instances of NetReaders.
It fetches all NetReaders by calling the Purge method. For each received OscBundle and for each OscElement the OscDispather fires an event (Bundle and Element)
Declaration Syntax
C# Visual Basic Visual C++
public class OscDispatcher
Public Class OscDispatcher
public ref class OscDispatcher
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscDispatcher()()() | Creates a new empty OscDispatcher
 | OscDispatcher(Boolean) | Creates a new empty OscDispatcher. If enableCache is set to true, the internal cache for TimeTags is activated. Received OscBundles are only dispatched if they are due! The received TimeTag will be compared to the DateTime value return by the GetDateTime method.
 | AddNetReader(NetReader) | Adds a NetReader to the OscDispatcher
 | Bundle | This event is thrown for each OscBundle received before the last call of Purge
 | ClearCache()()() | Clear all cached OscBundles
 | Element | This event is thrown for each OscElement received before the last call of Purge
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDateTime()()() | Override this method to return the correct DateTime for comparison with cached OscBundles. The default implementation returns DateTime.Now (in current system time zone)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Purge()()() | Purges all NetReaders in this Dispatcher and fires the events Bundle and Element.
 | RemoveNetReader(NetReader) | Removes a NetReader from the OscDispatcher
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
OscDispatcher


OscDispatcher Constructor

OscDispatcher Constructor
Namespaces ► Ventuz.OSC ► OscDispatcher ► OscDispatcher()()()
Members
Icon | Member | Description
 | OscDispatcher()()() | Creates a new empty OscDispatcher
 | OscDispatcher(Boolean) | Creates a new empty OscDispatcher. If enableCache is set to true, the internal cache for TimeTags is activated. Received OscBundles are only dispatched if they are due! The received TimeTag will be compared to the DateTime value return by the GetDateTime method.


OscDispatcher Constructor

OscDispatcher Constructor
Namespaces ► Ventuz.OSC ► OscDispatcher ► OscDispatcher()()()
Creates a new empty OscDispatcher
Declaration Syntax
C# Visual Basic Visual C++
public OscDispatcher()
Public Sub New
public:
OscDispatcher()


OscDispatcher Constructor (enableCache)

OscDispatcher Constructor (enableCache)
Namespaces ► Ventuz.OSC ► OscDispatcher ► OscDispatcher(Boolean)
Creates a new empty OscDispatcher. If enableCache is set to true, the internal cache for TimeTags is activated. Received OscBundles are only dispatched if they are due! The received TimeTag will be compared to the DateTime value return by the GetDateTime method.
Declaration Syntax
C# Visual Basic Visual C++
public OscDispatcher(
    bool enableCache
)
Public Sub New ( _
    enableCache As Boolean _
)
public:
OscDispatcher(
    bool enableCache
)
Parameters
enableCache (Boolean)
true, to enable the internal cache


AddNetReader Method (netReader)

AddNetReader Method (netReader)
Namespaces ► Ventuz.OSC ► OscDispatcher ► AddNetReader(NetReader)
Adds a NetReader to the OscDispatcher
Declaration Syntax
C# Visual Basic Visual C++
public void AddNetReader(
    NetReader netReader
)
Public Sub AddNetReader ( _
    netReader As NetReader _
)
public:
void AddNetReader(
    NetReader^ netReader
)
Parameters
netReader (NetReader)
the NetReader to add


Bundle Event

Bundle Event
Namespaces ► Ventuz.OSC ► OscDispatcher ► Bundle
This event is thrown for each OscBundle received before the last call of Purge
Declaration Syntax
C# Visual Basic Visual C++
public event OscBundleHandler Bundle
Public Event Bundle As OscBundleHandler
public:
 event OscBundleHandler^ Bundle {
    void add (OscBundleHandler^ value);
    void remove (OscBundleHandler^ value);
}


ClearCache Method

ClearCache Method
Namespaces ► Ventuz.OSC ► OscDispatcher ► ClearCache()()()
Clear all cached OscBundles
Declaration Syntax
C# Visual Basic Visual C++
public void ClearCache()
Public Sub ClearCache
public:
void ClearCache()


Element Event

Element Event
Namespaces ► Ventuz.OSC ► OscDispatcher ► Element
This event is thrown for each OscElement received before the last call of Purge
Declaration Syntax
C# Visual Basic Visual C++
public event OscElementHandler Element
Public Event Element As OscElementHandler
public:
 event OscElementHandler^ Element {
    void add (OscElementHandler^ value);
    void remove (OscElementHandler^ value);
}


GetDateTime Method

GetDateTime Method
Namespaces ► Ventuz.OSC ► OscDispatcher ► GetDateTime()()()
Override this method to return the correct DateTime for comparison with cached OscBundles. The default implementation returns DateTime.Now (in current system time zone)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual DateTime GetDateTime()
Protected Overridable Function GetDateTime As DateTime
protected:
virtual DateTime GetDateTime()
Return Value
DateTime of 'now'


Purge Method

Purge Method
Namespaces ► Ventuz.OSC ► OscDispatcher ► Purge()()()
Purges all NetReaders in this Dispatcher and fires the events Bundle and Element.
Declaration Syntax
C# Visual Basic Visual C++
public void Purge()
Public Sub Purge
public:
void Purge()


RemoveNetReader Method (netReader)

RemoveNetReader Method (netReader)
Namespaces ► Ventuz.OSC ► OscDispatcher ► RemoveNetReader(NetReader)
Removes a NetReader from the OscDispatcher
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveNetReader(
    NetReader netReader
)
Public Sub RemoveNetReader ( _
    netReader As NetReader _
)
public:
void RemoveNetReader(
    NetReader^ netReader
)
Parameters
netReader (NetReader)
the NetReader to remove


OscElement Class

OscElement Class
Namespaces ► Ventuz.OSC ► OscElement
OscElement holds the real data send/received to/from a OSC host in the network, so called Arguments. An OscElement is addressing an OSC address, which the receiver is listening to. One Element can transfer one or more data words. Following types are supported:
primitive types:
CopyC#
int, float, string, long, ulong, double, char, bool

complex types:
CopyC#
byte[] (binary data), OscSymbol, Color, OscMidiMessage

extended types (not part of the OSC specification):
CopyC#
OscUnicodeString, OscImage
Declaration Syntax
C# Visual Basic Visual C++
public class OscElement : OscMessage
Public Class OscElement _
    Inherits OscMessage
public ref class OscElement : public OscMessage
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
OscElement(String, array<Object>[]()[])
Creates an OscElement addressing the specified OSC Address and Arguments. The arguments are one or more of any supported types: primitive types:
CopyC#
int, float, string, long, ulong, double, char, bool

complex types:
CopyC#
byte[] (binary data), OscSymbol, Color, OscMidiMessage

extended types (not part of the OSC specification):
CopyC#
OscUnicodeString, OscImage

Address
Gets the OSC address this OscElement is addressing on the receivers side

Args
Gets the arguments the OscElement is holding.

Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize()()()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetHashCode()()()
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
GetRegex(String)
Generates a .NET Regular Expression by a given OSC address

GetType()()()
Gets the Type of the current instance.
(Inherited from Object.)
Infinitum
Constant argument to be used to transfer OSC-type 'Infinitum' ('I'). The value is float.PositiveInfinity

Match(String)
Returns true, if the Address of the OscElement matches the given address. Case sensitive!

MemberwiseClone()()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Regex
Get the .Net Regular Expression for the OSC address of this OscElement

ToStream(Stream)
Writes the OscElement to a stream in the format of an OscMessage:
1. Length of message
2. OSC Address Pattern
3. OSC Type Tag String
4. binary argument data
(Overrides OscMessage.ToStream(Stream).)
ToString()()()
Writes out a text dump of this OscElement.
(Overrides Object.ToString()()().)
ValidateAddressPattern(String)
Checks if a given OSC address is conforms the OSC address rules for address pattern matching multiple server addresses.
These are the matching rules for characters in the OSC Address Pattern:

CopyC#
'?' in the OSC Address Pattern matches any single character<br />
'*' in the OSC Address Pattern matches any sequence of zero or more characters<br />
A string of characters in square brackets (e.g., "[string]") in the OSC Address Pattern matches any character in the string. Inside square brackets, the minus sign (-) and exclamation point (!) have special meanings:<br />
1. two characters separated by a minus sign indicate the range of characters between the given two in ASCII collating sequence. (A minus sign at the end of the string has no special meaning.)<br />
2. An exclamation point at the beginning of a bracketed string negates the sense of the list, meaning that the list matches any character not in the list. (An exclamation point anywhere besides the first character after the open bracket has no special meaning.)<br />
A comma-separated list of strings enclosed in curly braces (e.g., "{foo,bar}") in the OSC Address Pattern matches any of the strings in the list.<br />
Any other character in an OSC Address Pattern can match only the same character.

ValidateServerAddress(String)
Checks if a given OSC address is conforms to the OSC address rules for a server address.

Inheritance Hierarchy
Object
 | OscMessage
 |  | OscElement


OscElement Constructor (address, args)

OscElement Constructor (address, args)
Namespaces ► Ventuz.OSC ► OscElement ► OscElement(String, array<Object>[]()[])
Creates an OscElement addressing the specified OSC Address and Arguments. The arguments are one or more of any supported types: primitive types:
CopyC#
int, float, string, long, ulong, double, char, bool

complex types:
CopyC#
byte[] (binary data), OscSymbol, Color, OscMidiMessage

extended types (not part of the OSC specification):
CopyC#
OscUnicodeString, OscImage
Declaration Syntax
C# Visual Basic Visual C++
public OscElement(
    string address,
    params Object[] args
)
Public Sub New ( _
    address As String, _
    ParamArray args As Object() _
)
public:
OscElement(
    String^ address,
    ... array<Object^>^ args
)
Parameters
address (String)
OSC address the OscElement is addressing
args (array< Object >[]()[])
list of arguments for this OscElement


Address Property

Address Property
Namespaces ► Ventuz.OSC ► OscElement ► Address
Gets the OSC address this OscElement is addressing on the receivers side
Declaration Syntax
C# Visual Basic Visual C++
public string Address { get; }
Public ReadOnly Property Address As String
public:
property String^ Address {
    String^ get ();
}


Args Property

Args Property
Namespaces ► Ventuz.OSC ► OscElement ► Args
Gets the arguments the OscElement is holding.
Declaration Syntax
C# Visual Basic Visual C++
public Object[] Args { get; }
Public ReadOnly Property Args As Object()
public:
property array<Object^>^ Args {
    array<Object^>^ get ();
}


GetRegex Method (address)

GetRegex Method (address)
Namespaces ► Ventuz.OSC ► OscElement ► GetRegex(String)
Generates a .NET Regular Expression by a given OSC address
Declaration Syntax
C# Visual Basic Visual C++
public static Regex GetRegex(
    string address
)
Public Shared Function GetRegex ( _
    address As String _
) As Regex
public:
static Regex^ GetRegex(
    String^ address
)
Parameters
address (String)
OSC address
Return Value
A valid Regex object


Infinitum Field

Infinitum Field
Namespaces ► Ventuz.OSC ► OscElement ► Infinitum
Constant argument to be used to transfer OSC-type 'Infinitum' ('I'). The value is float.PositiveInfinity
Declaration Syntax
C# Visual Basic Visual C++
public const float Infinitum
Public Const Infinitum As Single
public:
literal float Infinitum


Match Method (address)

Match Method (address)
Namespaces ► Ventuz.OSC ► OscElement ► Match(String)
Returns true, if the Address of the OscElement matches the given address. Case sensitive!
Declaration Syntax
C# Visual Basic Visual C++
public bool Match(
    string address
)
Public Function Match ( _
    address As String _
) As Boolean
public:
bool Match(
    String^ address
)
Parameters
address (String)
OSC Address to check for match
Return Value

[Missing <returns> documentation for M:Ventuz.OSC.OscElement.Match(System.String)]


Regex Property

Regex Property
Namespaces ► Ventuz.OSC ► OscElement ► Regex
Get the .Net Regular Expression for the OSC address of this OscElement
Declaration Syntax
C# Visual Basic Visual C++
public Regex Regex { get; }
Public ReadOnly Property Regex As Regex
public:
property Regex^ Regex {
    Regex^ get ();
}


ToStream Method (stream)

ToStream Method (stream)
Namespaces ► Ventuz.OSC ► OscElement ► ToStream(Stream)
Writes the OscElement to a stream in the format of an OscMessage:
1. Length of message
2. OSC Address Pattern
3. OSC Type Tag String
4. binary argument data
Declaration Syntax
C# Visual Basic Visual C++
public override void ToStream(
    Stream stream
)
Public Overrides Sub ToStream ( _
    stream As Stream _
)
public:
virtual void ToStream(
    Stream^ stream
) override
Parameters
stream (Stream)
stream to write the element to.


ToString Method

ToString Method
Namespaces ► Ventuz.OSC ► OscElement ► ToString()()()
Writes out a text dump of this OscElement.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:Ventuz.OSC.OscElement.ToString]


ValidateAddressPattern Method (address)

ValidateAddressPattern Method (address)
Namespaces ► Ventuz.OSC ► OscElement ► ValidateAddressPattern(String)
Checks if a given OSC address is conforms the OSC address rules for address pattern matching multiple server addresses.
These are the matching rules for characters in the OSC Address Pattern:

CopyC#
'?' in the OSC Address Pattern matches any single character<br />
'*' in the OSC Address Pattern matches any sequence of zero or more characters<br />
A string of characters in square brackets (e.g., "[string]") in the OSC Address Pattern matches any character in the string. Inside square brackets, the minus sign (-) and exclamation point (!) have special meanings:<br />
1. two characters separated by a minus sign indicate the range of characters between the given two in ASCII collating sequence. (A minus sign at the end of the string has no special meaning.)<br />
2. An exclamation point at the beginning of a bracketed string negates the sense of the list, meaning that the list matches any character not in the list. (An exclamation point anywhere besides the first character after the open bracket has no special meaning.)<br />
A comma-separated list of strings enclosed in curly braces (e.g., "{foo,bar}") in the OSC Address Pattern matches any of the strings in the list.<br />
Any other character in an OSC Address Pattern can match only the same character.
Declaration Syntax
C# Visual Basic Visual C++
public static void ValidateAddressPattern(
    string address
)
Public Shared Sub ValidateAddressPattern ( _
    address As String _
)
public:
static void ValidateAddressPattern(
    String^ address
)
Parameters
address (String)
OSC address to validate


ValidateServerAddress Method (address)

ValidateServerAddress Method (address)
Namespaces ► Ventuz.OSC ► OscElement ► ValidateServerAddress(String)
Checks if a given OSC address is conforms to the OSC address rules for a server address.
Declaration Syntax
C# Visual Basic Visual C++
public static void ValidateServerAddress(
    string address
)
Public Shared Sub ValidateServerAddress ( _
    address As String _
)
public:
static void ValidateServerAddress(
    String^ address
)
Parameters
address (String)
OSC address to validate


OscElementHandler Delegate

OscElementHandler Delegate
Namespaces ► Ventuz.OSC ► OscElementHandler
This event type is thrown by an OscDispatcher after calling OscDispatcher.Purge for each OscElement received on any NetReader attached to the OscDispatcher
Declaration Syntax
C# Visual Basic Visual C++
public delegate void OscElementHandler(
    OscDispatcher dispatcher,
    OscElement element
)
Public Delegate Sub OscElementHandler ( _
    dispatcher As OscDispatcher, _
    element As OscElement _
)
public delegate void OscElementHandler(
    OscDispatcher^ dispatcher,
    OscElement^ element
)
Parameters
dispatcher (OscDispatcher)
element (OscElement)


OscException Class

OscException Class
Namespaces ► Ventuz.OSC ► OscException
This exception is thrown, if any errors occured regarding the OSC protocol
Declaration Syntax
C# Visual Basic Visual C++
public class OscException : Exception
Public Class OscException _
    Inherits Exception
public ref class OscException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscException(String) | Creates an OscException with a specified message
 | OscException(String, Exception) | Creates an OscException with a specified message
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | OscException


OscException Constructor

OscException Constructor
Namespaces ► Ventuz.OSC ► OscException ► OscException()()()
Members
Icon | Member | Description
 | OscException(String) | Creates an OscException with a specified message
 | OscException(String, Exception) | Creates an OscException with a specified message


OscException Constructor (message)

OscException Constructor (message)
Namespaces ► Ventuz.OSC ► OscException ► OscException(String)
Creates an OscException with a specified message
Declaration Syntax
C# Visual Basic Visual C++
public OscException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
OscException(
    String^ message
)
Parameters
message (String)
message of the exception


OscException Constructor (message, innerException)

OscException Constructor (message, innerException)
Namespaces ► Ventuz.OSC ► OscException ► OscException(String, Exception)
Creates an OscException with a specified message
Declaration Syntax
C# Visual Basic Visual C++
public OscException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
OscException(
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
message of the exception
innerException (Exception)
inner exception caught by the OSC classes


OscGroup Class

OscGroup Class
Namespaces ► Ventuz.OSC ► OscGroup
The OscGroup allows to group multiple controls together so that all OscElements created by the Control are send in one OscBundle. To trigger the actual send of this bundle, you need to attach a Button to this OscGroup as well and set the GroupTrigger property to true.
Declaration Syntax
C# Visual Basic Visual C++
public class OscGroup : Component
Public Class OscGroup _
    Inherits Component
public ref class OscGroup : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscGroup()()() | Creates a new OscGroup Component
 | OscGroup(IContainer) | Creates a new OscGroup Component ans attaches it to the given container
 | Attach(OscManager, Control) | Attaches an OscManager and a Control to this OscGroup
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Detach(OscManager, Control) | Detaches an OscManager and a Control from this OscGroup
 | Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Send()()() | Send out all OscElements of all Controls in this OscGroup
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | OscGroup


OscGroup Constructor

OscGroup Constructor
Namespaces ► Ventuz.OSC ► OscGroup ► OscGroup()()()
Members
Icon | Member | Description
 | OscGroup()()() | Creates a new OscGroup Component
 | OscGroup(IContainer) | Creates a new OscGroup Component ans attaches it to the given container


OscGroup Constructor

OscGroup Constructor
Namespaces ► Ventuz.OSC ► OscGroup ► OscGroup()()()
Creates a new OscGroup Component
Declaration Syntax
C# Visual Basic Visual C++
public OscGroup()
Public Sub New
public:
OscGroup()


OscGroup Constructor (container)

OscGroup Constructor (container)
Namespaces ► Ventuz.OSC ► OscGroup ► OscGroup(IContainer)
Creates a new OscGroup Component ans attaches it to the given container
Declaration Syntax
C# Visual Basic Visual C++
public OscGroup(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
OscGroup(
    IContainer^ container
)
Parameters
container (IContainer)
container


Attach Method (manager, control)

Attach Method (manager, control)
Namespaces ► Ventuz.OSC ► OscGroup ► Attach(OscManager, Control)
Attaches an OscManager and a Control to this OscGroup
Declaration Syntax
C# Visual Basic Visual C++
public void Attach(
    OscManager manager,
    Control control
)
Public Sub Attach ( _
    manager As OscManager, _
    control As Control _
)
public:
void Attach(
    OscManager^ manager,
    Control^ control
)
Parameters
manager (OscManager)
OscManager
control (Control)
OscGroup


Detach Method (manager, control)

Detach Method (manager, control)
Namespaces ► Ventuz.OSC ► OscGroup ► Detach(OscManager, Control)
Detaches an OscManager and a Control from this OscGroup
Declaration Syntax
C# Visual Basic Visual C++
public void Detach(
    OscManager manager,
    Control control
)
Public Sub Detach ( _
    manager As OscManager, _
    control As Control _
)
public:
void Detach(
    OscManager^ manager,
    Control^ control
)
Parameters
manager (OscManager)
OscManager
control (Control)
OscGroup


Send Method

Send Method
Namespaces ► Ventuz.OSC ► OscGroup ► Send()()()
Send out all OscElements of all Controls in this OscGroup
Declaration Syntax
C# Visual Basic Visual C++
public void Send()
Public Sub Send
public:
void Send()


OscImage Structure

OscImage Structure
Namespaces ► Ventuz.OSC ► OscImage
Experimental!
The OscImage is an OSC extension (not specified in the OSC specification). OscImage allows to use an Image as an argument of an OscElement. The image is saved in PNG format and transferred as a binary argument where the first 4 bytes are filled with 'P' 'N' 'G' 'I' (PNG-Image)
If the receiving side uses the same Ventuz.OSC as well, the OscElement recognizes the argument as an OscImage. Other implementation will receive a binary data argument.
Declaration Syntax
C# Visual Basic Visual C++
public struct OscImage
Public Structure OscImage
public value class OscImage
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscImage(Image) | Creates an OscImage from a given Image
 | data | binary data of the Image (PNG-format)
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBytes()()() | Encodes the OscImage to its binary representation. the byte array is filled with 4 leading bytes: 'P' 'N' 'G' 'I'
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetImage(array<Byte>[]()[]) | Decodes a byte array into an Image.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsOscImage(array<Byte>[]()[]) | Tests if a byte array is marked with 'P' 'N' 'G' 'I'
 | length | length of used bytes in data
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


OscImage Constructor (image)

OscImage Constructor (image)
Namespaces ► Ventuz.OSC ► OscImage ► OscImage(Image)
Creates an OscImage from a given Image
Declaration Syntax
C# Visual Basic Visual C++
public OscImage(
    Image image
)
Public Sub New ( _
    image As Image _
)
public:
OscImage(
    Image^ image
)
Parameters
image (Image)
image to convert into an OscImage


data Field

data Field
Namespaces ► Ventuz.OSC ► OscImage ► data
binary data of the Image (PNG-format)
Declaration Syntax
C# Visual Basic Visual C++
public byte[] data
Public data As Byte()
public:
array<unsigned char>^ data


GetBytes Method

GetBytes Method
Namespaces ► Ventuz.OSC ► OscImage ► GetBytes()()()
Encodes the OscImage to its binary representation. the byte array is filled with 4 leading bytes: 'P' 'N' 'G' 'I'
Declaration Syntax
C# Visual Basic Visual C++
public byte[] GetBytes()
Public Function GetBytes As Byte()
public:
array<unsigned char>^ GetBytes()
Return Value
the byte array holding the encoded image including the mark


GetImage Method (b)

GetImage Method (b)
Namespaces ► Ventuz.OSC ► OscImage ► GetImage(array<Byte>[]()[])
Decodes a byte array into an Image.
Declaration Syntax
C# Visual Basic Visual C++
public static Image GetImage(
    byte[] b
)
Public Shared Function GetImage ( _
    b As Byte() _
) As Image
public:
static Image^ GetImage(
    array<unsigned char>^ b
)
Parameters
b (array< Byte >[]()[])
byte array to decode
Return Value
the decoded Image, or null if the byte array doesn't represent an encoded Image


IsOscImage Method (b)

IsOscImage Method (b)
Namespaces ► Ventuz.OSC ► OscImage ► IsOscImage(array<Byte>[]()[])
Tests if a byte array is marked with 'P' 'N' 'G' 'I'
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOscImage(
    byte[] b
)
Public Shared Function IsOscImage ( _
    b As Byte() _
) As Boolean
public:
static bool IsOscImage(
    array<unsigned char>^ b
)
Parameters
b (array< Byte >[]()[])
byte array to test
Return Value
true, if the first 4 bytes in buffer matche the mark


length Field

length Field
Namespaces ► Ventuz.OSC ► OscImage ► length
length of used bytes in data
Declaration Syntax
C# Visual Basic Visual C++
public int length
Public length As Integer
public:
int length


OscManager Class

OscManager Class
Namespaces ► Ventuz.OSC ► OscManager
The OscManagerComponent controls one OSC sending channels. All Controls attached to this Manager are sending their messages to the target OSC receiver specified in this manager
Declaration Syntax
C# Visual Basic Visual C++
public class OscManager : Component, IExtenderProvider,
    ISupportInitialize
Public Class OscManager _
    Inherits Component _
    Implements IExtenderProvider, ISupportInitialize
public ref class OscManager : public Component,
    IExtenderProvider, ISupportInitialize
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscManager()()() | Creates a new OscManager
 | OscManager(IContainer) | Creates a new OscManager and adds it to the given Container
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestIP | Destination IP this manager sends OscBundles to. (unicast or multicast)
 | DestPort | Destination Port number this manager sends OscBundles to.
 | Dispose(Boolean) | Disposes (closes) the OscManager and closes all open network sockets (Overrides Component.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(Control) | Creates an OscElement containing the arguments given by the control. e.g. the Text property of a TextBox The Control must be attachted to this manager to return a valid OscElement
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetAddress(Control) | Gets the OSC Element Address of an attached Control
 | GetGroup(Control) | Gets the OscGroup of an attached Control
 | GetGroupTrigger(Control) | Gets the GroupTrigger property of an attached Control
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnNetworkChanged()()() | Occurs if the network configuration has changed (DestIP or DestPort)
 | Send(OscBundle) | Sends an OscBundle to the destination as configured in the OscManager
 | SetAddress(Control, String) | Sets the OSC Element Address of an attached Control
 | SetGroup(Control, OscGroup) | Sets the OscGroup of an attached Control
 | SetGroupTrigger(Control, Boolean) | Sets the GroupTrigger property of an attached Control
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | OscManager


OscManager Constructor

OscManager Constructor
Namespaces ► Ventuz.OSC ► OscManager ► OscManager()()()
Members
Icon | Member | Description
 | OscManager()()() | Creates a new OscManager
 | OscManager(IContainer) | Creates a new OscManager and adds it to the given Container


OscManager Constructor

OscManager Constructor
Namespaces ► Ventuz.OSC ► OscManager ► OscManager()()()
Creates a new OscManager
Declaration Syntax
C# Visual Basic Visual C++
public OscManager()
Public Sub New
public:
OscManager()


OscManager Constructor (container)

OscManager Constructor (container)
Namespaces ► Ventuz.OSC ► OscManager ► OscManager(IContainer)
Creates a new OscManager and adds it to the given Container
Declaration Syntax
C# Visual Basic Visual C++
public OscManager(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
OscManager(
    IContainer^ container
)
Parameters
container (IContainer)

[Missing <param name="container"/> documentation for "M:Ventuz.OSC.OscManager.#ctor(System.ComponentModel.IContainer)"]


DestIP Property

DestIP Property
Namespaces ► Ventuz.OSC ► OscManager ► DestIP
Destination IP this manager sends OscBundles to. (unicast or multicast)
Declaration Syntax
C# Visual Basic Visual C++
public string DestIP { get; set; }
Public Property DestIP As String
public:
property String^ DestIP {
    String^ get ();
    void set (String^ value);
}


DestPort Property

DestPort Property
Namespaces ► Ventuz.OSC ► OscManager ► DestPort
Destination Port number this manager sends OscBundles to.
Declaration Syntax
C# Visual Basic Visual C++
public int DestPort { get; set; }
Public Property DestPort As Integer
public:
property int DestPort {
    int get ();
    void set (int value);
}


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Ventuz.OSC ► OscManager ► Dispose(Boolean)
Disposes (closes) the OscManager and closes all open network sockets
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)

[Missing <param name="disposing"/> documentation for "M:Ventuz.OSC.OscManager.Dispose(System.Boolean)"]


Evaluate Method (c)

Evaluate Method (c)
Namespaces ► Ventuz.OSC ► OscManager ► Evaluate(Control)
Creates an OscElement containing the arguments given by the control. e.g. the Text property of a TextBox The Control must be attachted to this manager to return a valid OscElement
Declaration Syntax
C# Visual Basic Visual C++
public OscElement Evaluate(
    Control c
)
Public Function Evaluate ( _
    c As Control _
) As OscElement
public:
OscElement^ Evaluate(
    Control^ c
)
Parameters
c (Control)
The control to form an OscElement for
Return Value
OscElement with address and argument of the given control, or null if the control is not managed by this manager


GetAddress Method (control)

GetAddress Method (control)
Namespaces ► Ventuz.OSC ► OscManager ► GetAddress(Control)
Gets the OSC Element Address of an attached Control
Declaration Syntax
C# Visual Basic Visual C++
public string GetAddress(
    Control control
)
Public Function GetAddress ( _
    control As Control _
) As String
public:
String^ GetAddress(
    Control^ control
)
Parameters
control (Control)
the control this extended property belongs to
Return Value
the IP address


GetGroup Method (control)

GetGroup Method (control)
Namespaces ► Ventuz.OSC ► OscManager ► GetGroup(Control)
Gets the OscGroup of an attached Control
Declaration Syntax
C# Visual Basic Visual C++
public OscGroup GetGroup(
    Control control
)
Public Function GetGroup ( _
    control As Control _
) As OscGroup
public:
OscGroup^ GetGroup(
    Control^ control
)
Parameters
control (Control)
the control this extended property belongs to
Return Value
OscGroup of the given Control


GetGroupTrigger Method (control)

GetGroupTrigger Method (control)
Namespaces ► Ventuz.OSC ► OscManager ► GetGroupTrigger(Control)
Gets the GroupTrigger property of an attached Control
Declaration Syntax
C# Visual Basic Visual C++
public bool GetGroupTrigger(
    Control control
)
Public Function GetGroupTrigger ( _
    control As Control _
) As Boolean
public:
bool GetGroupTrigger(
    Control^ control
)
Parameters
control (Control)
the control this extended property belongs to
Return Value
value GroupTrigger of the given Control


OnNetworkChanged Method

OnNetworkChanged Method
Namespaces ► Ventuz.OSC ► OscManager ► OnNetworkChanged()()()
Occurs if the network configuration has changed (DestIP or DestPort)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnNetworkChanged()
Protected Overridable Sub OnNetworkChanged
protected:
virtual void OnNetworkChanged()


Send Method (bundle)

Send Method (bundle)
Namespaces ► Ventuz.OSC ► OscManager ► Send(OscBundle)
Sends an OscBundle to the destination as configured in the OscManager
Declaration Syntax
C# Visual Basic Visual C++
public void Send(
    OscBundle bundle
)
Public Sub Send ( _
    bundle As OscBundle _
)
public:
void Send(
    OscBundle^ bundle
)
Parameters
bundle (OscBundle)

[Missing <param name="bundle"/> documentation for "M:Ventuz.OSC.OscManager.Send(Ventuz.OSC.OscBundle)"]


SetAddress Method (control, value)

SetAddress Method (control, value)
Namespaces ► Ventuz.OSC ► OscManager ► SetAddress(Control, String)
Sets the OSC Element Address of an attached Control
Declaration Syntax
C# Visual Basic Visual C++
public void SetAddress(
    Control control,
    string value
)
Public Sub SetAddress ( _
    control As Control, _
    value As String _
)
public:
void SetAddress(
    Control^ control,
    String^ value
)
Parameters
control (Control)
the control this extended property belongs to
value (String)
OSC Element Address


SetGroup Method (control, value)

SetGroup Method (control, value)
Namespaces ► Ventuz.OSC ► OscManager ► SetGroup(Control, OscGroup)
Sets the OscGroup of an attached Control
Declaration Syntax
C# Visual Basic Visual C++
public void SetGroup(
    Control control,
    OscGroup value
)
Public Sub SetGroup ( _
    control As Control, _
    value As OscGroup _
)
public:
void SetGroup(
    Control^ control,
    OscGroup^ value
)
Parameters
control (Control)
the control this extended property belongs to
value (OscGroup)
OscGroup of the given Control


SetGroupTrigger Method (control, value)

SetGroupTrigger Method (control, value)
Namespaces ► Ventuz.OSC ► OscManager ► SetGroupTrigger(Control, Boolean)
Sets the GroupTrigger property of an attached Control
Declaration Syntax
C# Visual Basic Visual C++
public void SetGroupTrigger(
    Control control,
    bool value
)
Public Sub SetGroupTrigger ( _
    control As Control, _
    value As Boolean _
)
public:
void SetGroupTrigger(
    Control^ control,
    bool value
)
Parameters
control (Control)
the control this extended property belongs to
value (Boolean)
value GroupTrigger of the given Control


OscMessage Class

OscMessage Class
Namespaces ► Ventuz.OSC ► OscMessage
OscMessage is the base class of OscElement and OscBundle. It represents the smallest to be send/received via the OSC protocol
Declaration Syntax
C# Visual Basic Visual C++
public abstract class OscMessage
Public MustInherit Class OscMessage
public ref class OscMessage abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OscMessage()()() | Initializes a new instance of the OscMessage class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromStream(Stream) | Reads an OSC message from a given stream.
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToStream(Stream) | Write the message to the stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | OscMessage
 |  | OscBundle
 |  | OscElement


OscMessage Constructor

OscMessage Constructor
Namespaces ► Ventuz.OSC ► OscMessage ► OscMessage()()()
Initializes a new instance of the OscMessage class
Declaration Syntax
C# Visual Basic Visual C++
protected OscMessage()
Protected Sub New
protected:
OscMessage()


FromStream Method (stream)

FromStream Method (stream)
Namespaces ► Ventuz.OSC ► OscMessage ► FromStream(Stream)
Reads an OSC message from a given stream.
Declaration Syntax
C# Visual Basic Visual C++
public static OscMessage FromStream(
    Stream stream
)
Public Shared Function FromStream ( _
    stream As Stream _
) As OscMessage
public:
static OscMessage^ FromStream(
    Stream^ stream
)
Parameters
stream (Stream)
The stream to read the OSC message from
Return Value
The read message can represent a bundle or an element


ToStream Method (stream)

ToStream Method (stream)
Namespaces ► Ventuz.OSC ► OscMessage ► ToStream(Stream)
Write the message to the stream.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void ToStream(
    Stream stream
)
Public MustOverride Sub ToStream ( _
    stream As Stream _
)
public:
virtual void ToStream(
    Stream^ stream
) abstract
Parameters
stream (Stream)

[Missing <param name="stream"/> documentation for "M:Ventuz.OSC.OscMessage.ToStream(System.IO.Stream)"]


OscMidiMessage Structure

OscMidiMessage Structure
Namespaces ► Ventuz.OSC ► OscMidiMessage
The OscMidiMessage structure combines the components of a Midi Message and allows to use it as an argument of an OscElement.
Declaration Syntax
C# Visual Basic Visual C++
public struct OscMidiMessage
Public Structure OscMidiMessage
public value class OscMidiMessage
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscMidiMessage(Byte, Byte, Byte, Byte) | Creates a new MidiMessage with the specified components of a Midi message. See Midi protocol specifications for further details.
 | Data1 | Data1 of the Midi message
 | Data2 | Data2 of the Midi message
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PortId | PortID of the Midi message
 | Status | Status of the Midi message
 | ToInt32()()() | Converts the Midi components to a 32 bit word (binary Midi message or short message)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


OscMidiMessage Constructor (portId, status, data1, data2)

OscMidiMessage Constructor (portId, status, data1, data2)
Namespaces ► Ventuz.OSC ► OscMidiMessage ► OscMidiMessage(Byte, Byte, Byte, Byte)
Creates a new MidiMessage with the specified components of a Midi message. See Midi protocol specifications for further details.
Declaration Syntax
C# Visual Basic Visual C++
public OscMidiMessage(
    byte portId,
    byte status,
    byte data1,
    byte data2
)
Public Sub New ( _
    portId As Byte, _
    status As Byte, _
    data1 As Byte, _
    data2 As Byte _
)
public:
OscMidiMessage(
    unsigned char portId,
    unsigned char status,
    unsigned char data1,
    unsigned char data2
)
Parameters
portId (Byte)
PortID component of a Midi message
status (Byte)
Status component of a Midi message
data1 (Byte)
Data1 component of a Midi message
data2 (Byte)
Data2 component of a Midi message


Data1 Field

Data1 Field
Namespaces ► Ventuz.OSC ► OscMidiMessage ► Data1
Data1 of the Midi message
Declaration Syntax
C# Visual Basic Visual C++
public byte Data1
Public Data1 As Byte
public:
unsigned char Data1


Data2 Field

Data2 Field
Namespaces ► Ventuz.OSC ► OscMidiMessage ► Data2
Data2 of the Midi message
Declaration Syntax
C# Visual Basic Visual C++
public byte Data2
Public Data2 As Byte
public:
unsigned char Data2


PortId Field

PortId Field
Namespaces ► Ventuz.OSC ► OscMidiMessage ► PortId
PortID of the Midi message
Declaration Syntax
C# Visual Basic Visual C++
public byte PortId
Public PortId As Byte
public:
unsigned char PortId


Status Field

Status Field
Namespaces ► Ventuz.OSC ► OscMidiMessage ► Status
Status of the Midi message
Declaration Syntax
C# Visual Basic Visual C++
public byte Status
Public Status As Byte
public:
unsigned char Status


ToInt32 Method

ToInt32 Method
Namespaces ► Ventuz.OSC ► OscMidiMessage ► ToInt32()()()
Converts the Midi components to a 32 bit word (binary Midi message or short message)
Declaration Syntax
C# Visual Basic Visual C++
public int ToInt32()
Public Function ToInt32 As Integer
public:
int ToInt32()
Return Value

[Missing <returns> documentation for M:Ventuz.OSC.OscMidiMessage.ToInt32]


OscSymbol Structure

OscSymbol Structure
Namespaces ► Ventuz.OSC ► OscSymbol
The OscSymbol is a special version of a string argument in an OscElement. It's not transferred as a simple string. It's using the Symbol tagging. See OSC specifications for further details.
Declaration Syntax
C# Visual Basic Visual C++
public struct OscSymbol
Public Structure OscSymbol
public value class OscSymbol
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscSymbol(String) | Creates an OscSymbol by the given symbol-content string
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Length | Get the length of the symbol content or zero if the symbol string is null (Nothing in VB)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Symbol | the Symbol content
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


OscSymbol Constructor (symbol)

OscSymbol Constructor (symbol)
Namespaces ► Ventuz.OSC ► OscSymbol ► OscSymbol(String)
Creates an OscSymbol by the given symbol-content string
Declaration Syntax
C# Visual Basic Visual C++
public OscSymbol(
    string symbol
)
Public Sub New ( _
    symbol As String _
)
public:
OscSymbol(
    String^ symbol
)
Parameters
symbol (String)
the content of the symbol


Length Property

Length Property
Namespaces ► Ventuz.OSC ► OscSymbol ► Length
Get the length of the symbol content or zero if the symbol string is null (Nothing in VB)
Declaration Syntax
C# Visual Basic Visual C++
public int Length { get; }
Public ReadOnly Property Length As Integer
public:
property int Length {
    int get ();
}


Symbol Field

Symbol Field
Namespaces ► Ventuz.OSC ► OscSymbol ► Symbol
the Symbol content
Declaration Syntax
C# Visual Basic Visual C++
public string Symbol
Public Symbol As String
public:
String^ Symbol


OscUnicodeString Structure

OscUnicodeString Structure
Namespaces ► Ventuz.OSC ► OscUnicodeString
The OscUnicodeString is an OSC extension (not specified in the OSC specification) It simply transfers a BigEndianUnicode encoded string (.NET-String) as a binary argument. The binary data is marked with the bytes 'B' 'E' 'U' 'C' (Big-Endian-Uni-Code) If the receiving side uses the same Ventuz.OSC as well, the OscElement recognizes the argument as an OscUnicodeString. Other implementation will receive a binary data argument.
Declaration Syntax
C# Visual Basic Visual C++
public struct OscUnicodeString
Public Structure OscUnicodeString
public value class OscUnicodeString
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OscUnicodeString(array<Byte>[]()[]) | Creates an OscUnicodeString from its binary representation
 | OscUnicodeString(String) | Creates an OscUnicodeString from a string
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBytes()()() | Encodes the OscUnicodeString to its binary representation. The byte array is filled with 4 leading bytes: 'B' 'E' 'U' 'C' so the shortest returned buffer has a length of 4
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetString(array<Byte>[]()[]) | Decodes a byte array into a string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsOscUnicodeString(array<Byte>[]()[]) | Tests if a byte array is marked with 'B' 'E' 'U' 'C'
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | String | The embedded string
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


OscUnicodeString Constructor

OscUnicodeString Constructor
Namespaces ► Ventuz.OSC ► OscUnicodeString ► OscUnicodeString()()()
Members
Icon | Member | Description
 | OscUnicodeString(array<Byte>[]()[]) | Creates an OscUnicodeString from its binary representation
 | OscUnicodeString(String) | Creates an OscUnicodeString from a string


OscUnicodeString Constructor (bin)

OscUnicodeString Constructor (bin)
Namespaces ► Ventuz.OSC ► OscUnicodeString ► OscUnicodeString(array<Byte>[]()[])
Creates an OscUnicodeString from its binary representation
Declaration Syntax
C# Visual Basic Visual C++
public OscUnicodeString(
    byte[] bin
)
Public Sub New ( _
    bin As Byte() _
)
public:
OscUnicodeString(
    array<unsigned char>^ bin
)
Parameters
bin (array< Byte >[]()[])

[Missing <param name="bin"/> documentation for "M:Ventuz.OSC.OscUnicodeString.#ctor(System.Byte[])"]


OscUnicodeString Constructor (String)

OscUnicodeString Constructor (String)
Namespaces ► Ventuz.OSC ► OscUnicodeString ► OscUnicodeString(String)
Creates an OscUnicodeString from a string
Declaration Syntax
C# Visual Basic Visual C++
public OscUnicodeString(
    string String
)
Public Sub New ( _
    String As String _
)
public:
OscUnicodeString(
    String^ String
)
Parameters
String (String)

[Missing <param name="String"/> documentation for "M:Ventuz.OSC.OscUnicodeString.#ctor(System.String)"]


GetBytes Method

GetBytes Method
Namespaces ► Ventuz.OSC ► OscUnicodeString ► GetBytes()()()
Encodes the OscUnicodeString to its binary representation. The byte array is filled with 4 leading bytes: 'B' 'E' 'U' 'C' so the shortest returned buffer has a length of 4
Declaration Syntax
C# Visual Basic Visual C++
public byte[] GetBytes()
Public Function GetBytes As Byte()
public:
array<unsigned char>^ GetBytes()
Return Value
the byte array holding the encoded string including the mark


GetString Method (b)

GetString Method (b)
Namespaces ► Ventuz.OSC ► OscUnicodeString ► GetString(array<Byte>[]()[])
Decodes a byte array into a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetString(
    byte[] b
)
Public Shared Function GetString ( _
    b As Byte() _
) As String
public:
static String^ GetString(
    array<unsigned char>^ b
)
Parameters
b (array< Byte >[]()[])
byte array to decode
Return Value
the decoded string, or null if the byte array doesn't represent an encoded string


IsOscUnicodeString Method (b)

IsOscUnicodeString Method (b)
Namespaces ► Ventuz.OSC ► OscUnicodeString ► IsOscUnicodeString(array<Byte>[]()[])
Tests if a byte array is marked with 'B' 'E' 'U' 'C'
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOscUnicodeString(
    byte[] b
)
Public Shared Function IsOscUnicodeString ( _
    b As Byte() _
) As Boolean
public:
static bool IsOscUnicodeString(
    array<unsigned char>^ b
)
Parameters
b (array< Byte >[]()[])
byte array to test
Return Value
true, if the first 4 bytes in buffer matches the mark


String Field

String Field
Namespaces ► Ventuz.OSC ► OscUnicodeString ► String
The embedded string
Declaration Syntax
C# Visual Basic Visual C++
public string String
Public String As String
public:
String^ String


UdpReader Class

UdpReader Class
Namespaces ► Ventuz.OSC ► UdpReader
An UdpReader receives OscBundles from UDP unicast or multicast sockets.
Declaration Syntax
C# Visual Basic Visual C++
public class UdpReader : NetReader
Public Class UdpReader _
    Inherits NetReader
public ref class UdpReader : public NetReader
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UdpReader(Int32) | Creates an UdpReader listening to the specified port number.
 | UdpReader(Int32, String) | Creates an UdpReader listening to the specified port number. The read joins the Multicast group specified.
 | UdpReader(Int32, String, Int32) | Creates an UdpReader listening to the specified port number. The read joins the Multicast group specified.
 | Dispose(Boolean) | Closes the UdpReader (Overrides NetBase.Dispose(Boolean).)
 | Dispose()()() | Disposes and closes a network connection (Inherited from NetBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Finalizer (Inherited from NetBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Receive()()() | Receives the OscBundle received by the reader. If a bundle was received to caller should call this method again to ensure a full fetched input buffer. (Overrides NetReader.Receive()()().)
 | ReceiveBundle()()() | Obsolete. Reads an OSC bundle from the network synchronously. If a bundle was received (a non null pointer was returned) the caller should call this method again to make sure that the whole input buffer was fetched completly. (Inherited from NetReader.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | NetBase
 |  | NetReader
 |  |  | UdpReader


UdpReader Constructor

UdpReader Constructor
Namespaces ► Ventuz.OSC ► UdpReader ► UdpReader()()()
Members
Icon | Member | Description
 | UdpReader(Int32) | Creates an UdpReader listening to the specified port number.
 | UdpReader(Int32, String) | Creates an UdpReader listening to the specified port number. The read joins the Multicast group specified.
 | UdpReader(Int32, String, Int32) | Creates an UdpReader listening to the specified port number. The read joins the Multicast group specified.


UdpReader Constructor (port)

UdpReader Constructor (port)
Namespaces ► Ventuz.OSC ► UdpReader ► UdpReader(Int32)
Creates an UdpReader listening to the specified port number.
Declaration Syntax
C# Visual Basic Visual C++
public UdpReader(
    int port
)
Public Sub New ( _
    port As Integer _
)
public:
UdpReader(
    int port
)
Parameters
port (Int32)
UDP Port number to listen to


UdpReader Constructor (port, multicastAddr)

UdpReader Constructor (port, multicastAddr)
Namespaces ► Ventuz.OSC ► UdpReader ► UdpReader(Int32, String)
Creates an UdpReader listening to the specified port number. The read joins the Multicast group specified.
Declaration Syntax
C# Visual Basic Visual C++
public UdpReader(
    int port,
    string multicastAddr
)
Public Sub New ( _
    port As Integer, _
    multicastAddr As String _
)
public:
UdpReader(
    int port,
    String^ multicastAddr
)
Parameters
port (Int32)
UDP Port number to listen to
multicastAddr (String)
multicast IP address to join


UdpReader Constructor (port, multicastAddr, bufferSize)

UdpReader Constructor (port, multicastAddr, bufferSize)
Namespaces ► Ventuz.OSC ► UdpReader ► UdpReader(Int32, String, Int32)
Creates an UdpReader listening to the specified port number. The read joins the Multicast group specified.
Declaration Syntax
C# Visual Basic Visual C++
public UdpReader(
    int port,
    string multicastAddr,
    int bufferSize
)
Public Sub New ( _
    port As Integer, _
    multicastAddr As String, _
    bufferSize As Integer _
)
public:
UdpReader(
    int port,
    String^ multicastAddr,
    int bufferSize
)
Parameters
port (Int32)
UDP Port number to listen to
multicastAddr (String)
multicast IP address to join
bufferSize (Int32)
size of udp receive buffer


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Ventuz.OSC ► UdpReader ► Dispose(Boolean)
Closes the UdpReader
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)

[Missing <param name="disposing"/> documentation for "M:Ventuz.OSC.UdpReader.Dispose(System.Boolean)"]


Receive Method

Receive Method
Namespaces ► Ventuz.OSC ► UdpReader ► Receive()()()
Receives the OscBundle received by the reader. If a bundle was received to caller should call this method again to ensure a full fetched input buffer.
Declaration Syntax
C# Visual Basic Visual C++
public override OscMessage Receive()
Public Overrides Function Receive As OscMessage
public:
virtual OscMessage^ Receive() override
Return Value
OscBundle received or null


UdpWriter Class

UdpWriter Class
Namespaces ► Ventuz.OSC ► UdpWriter
An UdpWriter sends OscBundles to a unicast or multicast IP address.
Declaration Syntax
C# Visual Basic Visual C++
public class UdpWriter : NetWriter
Public Class UdpWriter _
    Inherits NetWriter
public ref class UdpWriter : public NetWriter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UdpWriter(String, Int32) | Creates an UdpWriter sending OscBundles to the specified UDP IP address and port. The IP address can be a multicast IP, if you like to send the message to multiple hosts within the network.
 | Dispose(Boolean) | Closes the UdpWriter (Overrides NetBase.Dispose(Boolean).)
 | Dispose()()() | Disposes and closes a network connection (Inherited from NetBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Finalizer (Inherited from NetBase.)
 | GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Send(OscMessage) | Sends an OscBundle to the network (synchronously). (Overrides NetWriter.Send(OscMessage).)
 | SendBundle(OscBundle) | Obsolete. sends a bundle to the network (Inherited from NetWriter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | NetBase
 |  | NetWriter
 |  |  | UdpWriter


UdpWriter Constructor (address, port)

UdpWriter Constructor (address, port)
Namespaces ► Ventuz.OSC ► UdpWriter ► UdpWriter(String, Int32)
Creates an UdpWriter sending OscBundles to the specified UDP IP address and port. The IP address can be a multicast IP, if you like to send the message to multiple hosts within the network.
Declaration Syntax
C# Visual Basic Visual C++
public UdpWriter(
    string address,
    int port
)
Public Sub New ( _
    address As String, _
    port As Integer _
)
public:
UdpWriter(
    String^ address,
    int port
)
Parameters
address (String)
IP address (or Multicast-IP) to send to
port (Int32)
port number to send to


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Ventuz.OSC ► UdpWriter ► Dispose(Boolean)
Closes the UdpWriter
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
false, if called by the Garbage Collector


Send Method (message)

Send Method (message)
Namespaces ► Ventuz.OSC ► UdpWriter ► Send(OscMessage)
Sends an OscBundle to the network (synchronously).
Declaration Syntax
C# Visual Basic Visual C++
public override void Send(
    OscMessage message
)
Public Overrides Sub Send ( _
    message As OscMessage _
)
public:
virtual void Send(
    OscMessage^ message
) override
Parameters
message (OscMessage)
OscMessage to send


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► NetWriter ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Disposes and closes a network connection
 | Dispose(Boolean) | Disposes and closes a network connection


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Ventuz.OSC ► OscManager ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► OscManager ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Disposes (closes) the OscManager and closes all open network sockets (Overrides Component.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Component.


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► OscGroup ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the Component.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources.


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► UdpWriter ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Closes the UdpWriter (Overrides NetBase.Dispose(Boolean).)
 | Dispose()()() | Disposes and closes a network connection


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Ventuz.OSC ► OscGroup ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► NetReader ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Disposes and closes a network connection
 | Dispose(Boolean) | Disposes and closes a network connection


Dispose Method

Dispose Method
Namespaces ► Ventuz.OSC ► UdpReader ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Closes the UdpReader (Overrides NetBase.Dispose(Boolean).)
 | Dispose()()() | Disposes and closes a network connection